Direkt nach dem Update von Windows 8.1 auf Windows 10 war das Startmenü deaktiviert, das heißt weder Links- noch Rechtsklick auf den Startmenübutton funktionierten.
Im Internet gibt es verschiedene Lösungsansätze dafür, zum Beispiel auf der Website von chip.de. Geholfen hat bei mir allerdings nur die Kombination von EDB-Log löschen und die Reparatur des Startmenüs über die Powershell mit anschließendem Neustart des Systems.

In den folgenden Ausführungen setze ich als Benutzernamen „admin“ als Synonym für den Domain-Administrator unter dessen Namen meine Installationen erfolgten. Mit Standardbenutzerrechten lassen sich die beiden Schritte nicht ausführen. Bei einem Einzelplatz-PC ist also auch die Ausführung der Befehle als Administrator notwendig. 

Zunächst musste ich als Ursache der Startmenü-Probleme eine bestimmte Log-Datei von Windows 10 löschen.

  • Öffnen Sie im Windows Explorer den Pfad C:\Users\*admin*\AppData\Local\TileDataLayer\Database, wobei Sie *admin* durch Ihren Benutzernamen ersetzen müssen.
  • Suchen Sie nach einer Datei mit dem Namen EDB00001.log und löschen Sie diese. Statt "00001" kann im Dateinamen auch eine andere Zahl stehen. Löschen Sie dann diese.
  • Sollte sich die Datei nicht löschen lassen, müssen Sie den Dienst tiledatamodelsvc beenden (Taskmanager mit „Strg+Umschalt+Esc“ aufrufen, in Karteireiter Dienste wechseln und den Dienst tiledatamodelsvc stoppen).

Datei löschen

Anschließend musste ich den Reparaturvorgang über die Powershell starten:

  • Rufen Sie den Taskmanager auf („Strg + Umschalt + Esc“).
  • Klicken Sie unten links auf Mehr Details.
  • Suchen Sie im Bereich Windows-Prozesse nach dem Eintrag Windows Explorer. Klicken Sie ihn mit der rechten Maustaste an und wählen Sie im Kontextmenü Task beenden aus.
  • Klicken Sie in der Menüleiste des Task-Managers zuerst auf Datei und anschließend auf Neuen Task ausführen. Tippen Sie als nächstes Powershell ein.
  • Im Fenster der Powershell geben Sie folgenden Befehl ein:

    Get-appxpackage -all *shellexperience* -packagetype bundle |% {add-appxpackage -register -disabledevelopmentmode ($_.installlocation + “\appxmetadata\appxbundlemanifest.xml”)}

  • Nach Abschluss des Befehls, geben Sie noch diesen ein:

    Get-AppxPackage | % { Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppxManifest.xml" -verbose }

(Empfehlung: Nutzen Sie Copy and Paste um den „kryptischen“ Befehl von hier in Ihre Powershell zu übertragen).

powershell

Nach dem Neustart des Explorers über den Taskmanager sollte das Startmenü wieder funktionieren. So lauteten die Empfehlungen auf verschiedenen Websites. Bei mir funktionierte dies nicht! Erst ein Neustart des Systems brachte den gewünschten Erfolg. Der geschilderte Fall mit dem defekten Startmenü trat innerhalb kurzer Zeit auf zwei PC in einem Netzwerk auf, danach nicht mehr. 

Joomla Template by Joomla51.com